Increase in errors with one of our email providers
Incident Report for ReviewTrackers
Resolved
Our provider has fixed the issue. We are sending out all delayed request emails.
Posted about 1 year ago. Feb 23, 2018 - 09:43 CST
Identified
One of our email providers is experiencing downstream issues with validating email addresses. Request email delivery has been temporarily delayed until the issue is resolved.
Posted about 1 year ago. Feb 23, 2018 - 08:12 CST