DDoS Attack on Data Center
Incident Report for ReviewTrackers
Resolved
This incident has been resolved. We are continuing to monitor for any further issues.
Posted over 2 years ago. Oct 21, 2016 - 09:45 CDT
Monitoring
Our data center and DNS providers are currently experiencing a large scale DDoS attack. Some users are experiencing degraded experience. Working to resolve, updates to follow.
Posted over 2 years ago. Oct 21, 2016 - 07:45 CDT