Platform Outage
Incident Report for ReviewTrackers
Resolved
Our platform is stable and operating as expected.

Thank you for your patience.
Posted Aug 15, 2022 - 17:38 CDT
Identified
An upstream provider is experiencing an outage. We have reached out to them concerning the matter and believe they will fix the issue shortly.

We are sorry for any inconvenience.
Posted Aug 15, 2022 - 17:24 CDT
This incident affected: Dashboard & API, Data Collection, and Mail Delivery.