Known Issues with IE11
Incident Report for ReviewTrackers
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 04, 2019 - 14:57 CDT
Identified
We found the root cause, a service provider script was throwing errors in IE. We are working on a fix and will be informing the service provider of their issue. We expect resolution within a couple hours.
Posted about 2 months ago. Sep 04, 2019 - 10:55 CDT
Investigating
We are investigating an issue with IE11 relating to our app functionality. The issue is not present in modern Chrome versions.

We will keep this page updated as we progress. We are sorry for any inconvenience.
Posted about 2 months ago. Sep 04, 2019 - 09:28 CDT