Temporary Email Outage
Incident Report for ReviewTrackers
Resolved
This incident is now resolved. Delayed mail is now sending.
Posted Feb 24, 2021 - 18:59 CST
Identified
Ask campaigns, password reset and other emails sent from our platform are currently suspended due to a service provider outage.

We will update when the issue is fixed.
Posted Feb 24, 2021 - 17:40 CST
This incident affected: Mail Delivery.