Widespread Amazon Web Services Issues
Incident Report for ReviewTrackers
Resolved
All services have returned to normal.
Posted over 2 years ago. Feb 28, 2017 - 18:59 CST
Update
Amazon has identified the issue and has brought back the majority of functionality. However, a few issues remain and may cause issues with uploading CSVs when utilizing the "Request Reviews" feature of ReviewTrackers.
Posted over 2 years ago. Feb 28, 2017 - 15:56 CST
Update
AWS is starting to recover and the impact on our customer experience is improving. We are continuing to monitor the issue and will update this page as we know more.
Posted over 2 years ago. Feb 28, 2017 - 15:54 CST
Monitoring
Amazon Web Services, specifically S3 (Simple Storage Service), is currently experiencing issues that is beginning to degrade the experience for our customers. This is not an isolated incident and is affecting large portions of the internet. We are monitoring the situation and will provide updates as the the situation changes. The Customer Dashboard and API are largely unaffected, but some features, such as PDF Generation, are slow to respond and may timeout.
Posted over 2 years ago. Feb 28, 2017 - 13:42 CST