ReviewTrackers experiencing issues
Incident Report for ReviewTrackers
Resolved
Access to the ReviewTrackers platform has been restored.
Posted about 2 years ago. Mar 24, 2017 - 11:39 CDT
Identified
An issue with ReviewTrackers has been identified and a fix is rolling out immediately. Logins, API access, etc will be sporadic.
Posted about 2 years ago. Mar 24, 2017 - 11:35 CDT