Platform Outage
Incident Report for ReviewTrackers
Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 11:28 CST
Identified
All of our applications are currently down due to a service provider issue. We are waiting for service to get restored.

Thank you for your patience.
Posted Feb 24, 2022 - 10:37 CST
This incident affected: Dashboard & API, Data Collection, and Mail Delivery.