Service Provider Causing Platform Latency
Incident Report for ReviewTrackers
Resolved
Service response time is returning to normal. We are sorry for the inconvenience.
Posted over 1 year ago. Oct 16, 2017 - 16:24 CDT
Identified
A service provider we rely on is currently facing issues causing our platform to perform less optimally than we like or expect. We are sorry for the inconvenience and will be updating our status page accordingly.
Posted over 1 year ago. Oct 16, 2017 - 16:07 CDT